Die Datenbankverbindung von recotech können Sie mit dem Programm ConnectionEditor bequem anpassen und überprüfen. Dazu starten Sie recotech aber melden sich nicht am System an. Rechts neben der Datenbankauswahl können Sie das Verwaltungstool für die Datenbanken starten.




Sobald das Programm gestartet ist, sehen Sie folgende Oberflächen.



Hier sehen Sie die aktuell eingerichteten Verbindungen für recotech zu den entsprechenden Datenbanken.

Bei jedem Klick auf einen Datenbankeintrag wird die Datenbank auf Aktualität überprüft. Sollte das Tool ein Update für die Datenbank finden, wird dieses in der Spalte "Version" ausgegeben. Über Bearbeiten > Datenbankupdate können Sie die Datenbank anheben, so dass diese mit der aktuellen recotech Version wieder lauffähig ist. Das Update wird im Unteren Fenster "Log" protokolliert.



Neue Datenbankverbindung erstellen

Um eine neuen Verbindung zu definieren (Datei > Neu) oder eine vorhanden zu bearbeiten (Bearbeiten) gehen Sie wie folgt vor:


Datei > Neu (für eine neue Datenbankverbindung)


Name der Verbindung eingeben

Hier kann ein beliebiger Name gewählt werden, der jedoch eindeutig gegenüber den anderen Verbindungsnamen sein muss.

Dieser Name taucht beim Starten von recotech als Auswahl auf.

Verbindungsparameter definieren

Folgende Parameter müssen hier eingegeben werden:

  • der Name des DB-Servers (Listenauswahl)
  • Login-Information  (Speichern-Häkchen setzen!)
  • Datenbank (meist: recotech)

Nach dem Bestätigen ist der Name noch blau gekennzeichnet,  da diese Änderungen noch nicht gespeichert wurden.

Das rote „False“ lässt sich durch die Überprüfung der Verbindungen über das Menü „Tools“ -> „Tests“ beheben, wenn die eingegeben Parameter korrekt sind.



Mit dem Speichern über das Menü Datei > Speichern werden die angezeigten Verbindungen ins recotech geschrieben und stehen damit im Anmeldedialog zur Verfügung.